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1  BlockSim Training Guide

1.1  About this Training Guide
This training guide is intended to provide you with many examples of BlockSim. This training guide
begins with step-by-step examples and then proceeds into more advanced examples and questions. At
any time during the training, please feel free to ask the instructor(s) any questions you might have.

1.2  BlockSim Documentation
Like all of ReliaSoft's standard software
products, BlockSim is shipped with detailed
printed documentation on the product
(BlockSim User's Guide) and the underlying
principles and theory (ReliaSoft's System
Reliability Reference). This training guide is
intended to be a supplement to those
references.
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1.3  Contacting ReliaSoft
ReliaSoft can be reached at:

ReliaSoft Corporation
ReliaSoft Plaza

115 South Sherwood Village Drive
Tucson, AZ 85710   USA
Phone: +1.520.886.0366

Fax: +1.520.886.0399
E-mail: Support@ReliaSoft.com

For up-to-date product information, visit our Web site at: 
http://BlockSim.ReliaSoft.com 



2  Features Summary

The examples in this training guide have been designed to introduce you to the features available in
BlockSim. This section presents a brief summary of these features. If you are already familiar with
BlockSim’s features, you can proceed to Chapter 3, First Steps.

2.1  Using BlockSim
BlockSim allows you to analyze any process or product to obtain exact system reliability results
(including system reliabilities, mean times, failure rates, etc.), to calculate the optimum scenario to
meet system reliability goals and to obtain maintainability/availability results through simulation.
BlockSim's blocks can be defined with the reliability characteristics of each component of the process
or product. You can then configure these blocks into a reliability block diagram (RBD) that represents
the reliability-wise configuration of the system and analyze the diagram in order to determine the
reliability function (cumulative density function or cdf) of the entire system. This analysis can be used
to make statistical calculations and create plots, to perform “what-if” analyses, to determine the
optimization of system reliability to meet time and cost goals that you specify and to perform
maintainability/availability and reliability simulations.

2.2  Intuitive Work Environment
BlockSim's interface is an intelligent, flexible and completely integrated work center. The work
environment is designed around the Multiple Document Interface (MDI) and BlockSim's Project
Explorer. These tools allow you to display and manage the diagrams, spreadsheets, plot sheets,
templates and FRED report sheets you will create and use in BlockSim. From within BlockSim's
MDI, you can use BlockSim's integrated calculation and plotting tools to analyze your diagrams,
make system reliability calculations, create and modify plots and graphics and calculate the optimum
reliability scenario. You can also easily interact with other ReliaSoft and Windows applications. This
is all included in one comprehensive, easy-to-use package. 
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2.3  Easy to Use
ReliaSoft's BlockSim was designed and built for Microsoft Windows and takes full advantage of the best
features Windows has to offer. Using the familiar Windows interface, as well as the examples and help
provided, you can be up and running from the moment the application is installed. You can be productive
immediately, without the normal down-time you would expect when learning a new software application.
But making it easy does not mean we made it less powerful. BlockSim comes packed with advanced
features that you will find indispensable and you will learn and master them as you explore the software.
Complete Windows on-line help is also provided.

2.4  Blocks and Templates
BlockSim's blocks are the building blocks with which you will create complex reliability block diagrams.
You start with BlockSim's templates, which contain pre-defined sets of re-usable blocks. BlockSim provides
a gallery of templates to get you started and provides you with the flexibility to manage these collections of
building blocks to meet your specific needs. You can customize individual blocks with the failure, repair,
maintenance and reliability optimization characteristics for each component in your system. You can also
define BlockSim's blocks with the included failure/repair distributions, define your own distribution or
specify a fixed reliability value for the component at a specified point in time or without respect to time. 

2.5  Available Life Distributions
The life distributions available within BlockSim to define the failure and repair characteristics of system
components include the Weibull, Exponential, Normal, Lognormal and Mixed Weibull (with two, three or
four subpopulations) distributions. BlockSim also provides the capability to compute the appropriate
distribution and parameters for a component using ReliaSoft's Weibull++ life data analysis software. 

2.5.1  Integration with Weibull++
The capabilities of ReliaSoft's suite of reliability engineering software products have been designed to
complement one another. With BlockSim, we introduce a new level of integration. You can use an existing
*.wdf file created in ReliaSoft's Weibull++ software to define the failure or repair characteristics of a
BlockSim block and even use Weibull++ to compute the distribution and parameters “on the fly” from
within BlockSim. ReliaSoft's Weibull++ must be installed on your computer in order to utilize this option.
Contact ReliaSoft for information on obtaining this powerful life data analysis application.

2.6  System Reliability Block Diagrams
Simple drag-and-drop functionality allows you to drag blocks from a template into a diagram sheet and
configure those blocks to create simple or complex reliability block diagrams (RBDs). With BlockSim, you
can diagram systems with series, parallel and “k-out-of-n” reliability-wise configurations, as well as
complex combinations of those configuration types. You can also customize the size and shape of
component blocks, connecting lines, diagram background, graphics and text.

2.6.1  Template Blocks
Template blocks are the main building blocks of your reliability block diagrams. You can define these re-
usable blocks with the failure, repair, maintenance and reliability optimization characteristics of the
components they represent. BlockSim's template blocks allow you to define the characteristics of a
component once and use the same block in many RBDs to save time.

2.6.2  Node Blocks
Node blocks are another type of block that can be used in the reliability block diagrams you create. Node
blocks act as switches through which RBD paths move. You can specify how many paths leading into a node
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must be operational in order for the node to function. You can also define the properties of the node itself,
including whether it can fail and its failure distribution.

2.6.3  Subdiagram Blocks
In addition to the complex reliability-wise configurations supported by BlockSim's diagram sheets, you can
also link diagrams by using existing RBDs as components in other diagrams. BlockSim's Block As Diagram
option creates a block which represents the reliability characteristics of an existing BlockSim diagram. This
block serves as a subdiagram to the current diagram. This subdiagram block can then be placed into any
diagram as a component. You can even place these subdiagram blocks into a template so that they can easily
be re-used in other diagrams.

2.7  Unparalleled Plots and Graphs
BlockSim offers unparalleled plots and graphics capabilities. With the click of a button, you can create
Reliability vs. Time, Probability of Failure vs. Time, pdf, Failure Rate vs. Time, Static Reliability
Importance, Reliability Importance vs. Time and Availability vs. Time plots based on system RBDs. You
also have the flexibility to create a variety of plots and graphs with the Chart Wizard in BlockSim's
spreadsheets. With the Chart Designer, any of these graphs can be extensively customized to meet your
particular needs. All BlockSim plots can be saved as Windows metafile (*.wmf) graphics that can be used in
other applications. 

2.8  Quick Calculation Pad
ReliaSoft's Quick Calculation Pad (QCP) provides a quick, easy and accurate way for you to obtain exact
results for the most frequently asked reliability questions. From standard probability and mean time
calculations, to optimization algorithms, it is all possible using the QCP. All QCP results can be displayed
and manipulated in the Results Panel and flexible spreadsheets.

2.8.1  Reliability Metrics
BlockSim's powerful analysis engines analyze the diagrams you create in order to obtain the complete
mathematical system reliability function (or cumulative density function, cdf). You can use that real system
cdf and not just a simple simulation, to obtain exact reliability results from BlockSim's Quick Calculation
Pad (QCP). Calculations include reliability, probability of failure, conditional reliability, conditional
probability of failure, failure rate, warranty time, B(X) information and mean time.

2.8.2  “What-If” Analyses
In addition to providing quick, easy reliability calculations for the system diagrams you create, BlockSim
provides you with the flexibility to manipulate a diagram in order to perform “what-if” analyses. BlockSim
allows you to mark a component (or components) as inactive (i.e. failed, off or absent from the system) and
use the QCP to determine reliability metrics of the system under those hypothetical conditions. 

2.8.3  Optimize System Reliability
You can also use BlockSim's QCP to calculate the best way to optimize system reliability based on time and
cost goals that you provide. You can specify system reliability and time goals and select components to be
considered when calculating the optimum scenario for meeting those goals. Based on your specification of
the feasibility (or cost) of improving the reliability of each individual component, BlockSim calculates an
optimization algorithm that returns the optimum scenario for increasing component reliability in order to
achieve a system reliability goal. You can use BlockSim’s feasibility functions or specify your own
customized functions to describe the cost feasibility for increasing the reliability of a specific component.
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2.9  Reliability and Maintainability/Availability Simulations
In addition to calculating the exact mathematical system reliability function for your system diagrams,
BlockSim also provides a simulation utility. With this tool, you can perform simulations based on a linked
RBD to estimate the system reliability (and failure rate) or to obtain system maintainability/availability
results for a specified period of time. 

2.10  Spreadsheets
With BlockSim's spreadsheets, you can unleash endless possibilities. These spreadsheets can be used just as
you would use an Excel or Quattro spreadsheet with complete in-cell formula support, cell references and
over 140 built-in functions. Use this flexibility, coupled with all of the powerful data analysis capabilities of
BlockSim, to perform calculations, create plots and graphs and prepare presentations of your analyses. The
capabilities of BlockSim's spreadsheets are limited only by your imagination and creativity.

2.11  Report Work Center
ReliaSoft's Report Work Center (RWC) allows you to streamline and automate report creation. Comprised of
two pages, the Editor and the Template, the RWC works both as a traditional word processing utility and
also as a report generator. Using the Function Wizard, you can create forms with fields in the RWC Template
page that are filled in with the correct data in the Editor page. The RWC also includes a Web Publish option
that converts the Report Work Center document into HTML and allows you to preview the Internet/intranet-
ready document.

2.12  Function Wizard
Use ReliaSoft's Function Wizard in conjunction with BlockSim's spreadsheets and Report Work Center to
generate a variety of calculated results. The Function Wizard returns results based on a linked RBD. Results
include tables of failure rates given a time range, mean times of the system, reliability given time and more.
Use these results to create graphs and reports to present your analyses.

2.13  Graph File Manager
The appearance of BlockSim blocks can be customized with bitmap graphics. Select a bitmap from the
graphics library to be displayed on your blocks or use your own bitmap (*.bmp) files. Organize and preview
all of your bitmap graphics using the Graph File Manager. Preview the graphics within a particular directory
before choosing one to be displayed on the selected block. 

2.14  Customize the Application
BlockSim provides a User Setup that allows you to customize the application to meet your particular needs.
The User Setup allows you to configure the software to suit the way you and your company work.
Customize the way the software works or use the preferences pre-set by ReliaSoft. You can set the entire
look and feel of the software. For example, you can determine the decimal place accuracy you would like to
see, for up to fifteen decimal places. You can also decide whether results are displayed in percent or in
decimal format. 

2.15  A Note on Calculations
The results generated by BlockSim's analysis tools do not specify the units (e.g. hours, miles, etc.) for the
values returned. It must be understood that the units for the results are the same as the units for the data
inputs on which results are based. For this reason, BlockSim requires a uniformity of units among the
property definitions of blocks in diagram sheets and required inputs for calculations. For example, all time
values in a diagram sheet and in the analysis tools used to generate results based on that diagram must be
defined with the same units.



3  First Steps

3.1  Starting BlockSim
BlockSim is a 32-bit application that has been designed to work with Windows 95, Windows 98,
Windows Me, Windows NT and Windows 2000. To start BlockSim, from Start select Programs,
ReliaSoft Office, BlockSim and then BlockSim. The figures used in this manual, as well as the
commands required, are all from Windows 98. However, regardless of which operating system you
are using, the BlockSim internal screens and commands are identical in all systems and this manual is
equally applicable.
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3.2  Multiple Document Interface 
The Multiple Document Interface (MDI) is the main window and “manager” for BlockSim. The MDI serves
as the container for all the windows you will use in BlockSim. 

The menu and toolbar options available within BlockSim's MDI will vary depending on the windows that
are currently open. In addition, BlockSim's flexible MDI allows the user to configure the work space to meet
individual needs by hiding or moving the menu bar, toolbars, Project Explorer and Template Panel. 

The next figure displays the MDI and its components so that you can familiarize yourself with the options
available within the MDI. Your screen may look slightly different than the one shown next, depending on the
windows and tools currently open and on the configuration settings that you have established. 

3.3  Getting Help in the BlockSim Environment
ReliaSoft's BlockSim includes complete on-line help documentation. This help can be obtained at any time
by pressing F1 or by selecting Contents from the Help menu. 

3.4  BlockSim: A Familiarization

3.4.1  A Quick Overview Example
This section presents you with a very simple example and guides you through the solution. A simple system
consists of three resistors configured reliability-wise in series. The failure characteristics of each component
are presented in the table shown next. Create a reliability block diagram (RBD) to represent the system, plot
the Reliability vs. Time of the system and calculate the reliability of the system at 50 days of operation.

Component Failure Distribution Parameters

Resistor 1 Exponential Mean Time = 1000
Gamma = 0

Resistor 2 Exponential Mean Time = 500
Gamma = 0

Resistor 3 Exponential Mean Time = 333.33
Gamma = 0
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3.4.2  Create a New BlockSim Project
• The first step is to create a new project by clicking the New Project icon,

or by selecting New Project from the File menu. 

• The Template Preview window will be displayed to allow you to select an existing template or create a
new template in the new project.

• For this example, you will create a new template within the project. Click the New Template button in
the Template Preview window to open a new template in the project. 1

• After you click New Template, you will be prompted to enter a name for the new template. Click OK to
accept the default name. When you are prompted to enter a name for the new diagram sheet, which will
also be created in the new project, click OK to accept the default name. 

The Template Preview window allows you to preview and select from the existing BlockSim
templates in the current directory. BlockSim's templates contain sets of re-usable pre-defined
blocks, template blocks, which you can drag into the diagram sheets to create reliability block
diagrams (RBDs). Select a template name from the template list to display the blocks the
template contains in the preview area on the left. Click Select or double-click the template
name to close the Template Preview window and open the selected template in the project.
Click Browse to open a Browse For Folder window, which allows you to locate other
previously saved templates in other directories. Click New Template to close the Template
Preview window and create a new template in the project.

1. If the Do not show when creating new Projects option is selected, the Template Preview window will not be dis-
played when a new project is created. This selection can be reset on the Other page of the User Setup.
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• The Template Panel, located on the left side of the MDI, will appear once you create a new template.2
Notice that the Template Name Bar located at the top of the Template Panel displays the name of the
new template, New Template, and that the Template Name Bar is yellow to indicate that the template is
currently active.

2. The Template Panel will only appear if Show Template Panel is selected from the Template menu.

Multiple templates can be open at the same time within BlockSim. For each open
template, a Template Name Bar will be displayed in the Template Panel. When you
click a Template Name Bar, the template becomes active, the Template Name Bar
becomes yellow and the blocks associated with the template are displayed in the
Template Panel.
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• A new diagram sheet will also appear in the MDI, as shown next.

The Project Explorer will also appear in the MDI. The Project Explorer allows you to manage the files
included in a single BlockSim project. From within the Project Explorer, you can add, import, export,
rename and delete files within the current project.

The appearance of the Project Explorer will vary depending on whether Dock Project Explorer is selected
from either the Project Explorer shortcut menu or from the View menu.3 If Dock Project Explorer is
selected, the Project Explorer will be displayed as a fixed panel on the right side of the MDI. If Dock

The diagram sheet is the work space in which you will create simple or complex
RBDs. You can configure blocks and relationship lines in the diagram workspace. At
the bottom of the diagram sheet, the Status Box displays the analysis status (EDIT or
Analyzed) of the diagram, the Command Buttons allow you to initiate analyses based
on the diagram. Block Count displays the number of blocks in the diagram workspace
and Path Count displays the number of paths that have been defined in the diagram
sheet. 

3. Right-click inside the Project Explorer to display a shortcut menu with the commands that pertain to BlockSim
projects.
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Project Explorer is not selected, the Project Explorer will be displayed as a window like the one shown
next.

3.4.3  Creating a Template Block
The next step is to create a new template block that will be used as the pattern for the Resistor blocks you
will use in your RBD. BlockSim blocks, defined with the reliability characteristics of system components,
are the building blocks you will use to create your diagrams.

• To add a block to the active template, select Add New Block from the Template menu or click the Add
New Block icon in the Template toolbar.

The Block Properties window will appear, as shown next, which allows you to define the new block with the
life characteristics of the component.

• On the Failure page of the Block Properties window, you will define the block to represent the failure
characteristics of the Resistor 1 component. Type Resistor 1 in the Block Name input box. Verify that

To perform your system analyses with BlockSim, you will create diagrams,
spreadsheets, plots, templates and FRED reports. BlockSim allows you to store
and organize the diagrams, spreadsheets, plots, templates and FRED reports
related to a particular project together in a single file, a BlockSim project file
(*.rsw).
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the Block Can Fail option is selected (i.e. the checkbox is checked).4 Verify that the Static Block
option at the bottom of the window is not selected. 5

• Select Exponential under Failure Distribution and notice that the parameter input boxes to the right
change to represent the parameter requirements of the selected distribution. Type 1000 for the value of
Mean Time and 0 for the value of Gamma.6 Click Graph to update the pdf plot in the graphics screen to
the right. The pdf plot will now represent the current Failure page selections. 

• The Block Properties window will look like the one shown next. 

• Click OK to close the Block Properties window and create a new block in the active template.

4. The Block Can Fail option is selected to indicate that the component can fail. If the Block Can Fail option is not
selected, the reliability of the block at all times is considered to be 1 or 100% and the other options on the Failure page
will be unavailable.
5. The Static Block option is not selected to indicate that a time-dependent failure distribution will be defined for the
component. If the Static Block option is selected, an input box will appear in which you can type the reliability of the
component at a fixed point in time and the other options on the Failure page will be unavailable.
6. By default in BlockSim, the Exponential parameter is defined as mean time. Although the mean time definition is
appropriate for this example, you can also define the Exponential parameter as Lambda from the Calculations page of
the User Setup.
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• The Template Panel now holds a new block, as shown next.

• Repeat these steps to create two more template blocks to represent the Resistor 2 and Resistor 3
components. On the Failure page of the Block Properties window for the Resistor 2 block, make the
following selections:

Block Name: Resistor 2

Block Can Fail: Selected 

Failure Distribution: Exponential

Mean Time: 500

Gamma: 0

Static Block: Not Selected

• On the Failure page of the Block Properties window for the Resistor 3 block, make the following
selections:

Block Name: Resistor 3

Block Can Fail: Selected 

Failure Distribution: Exponential

Mean Time: 333.33

Gamma: 0

Static Block: Not Selected
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3.4.4  Build a Simple Diagram
Now you are ready to build a simple reliability block diagram (RBD) by placing the template blocks you
have created into the diagram sheet. You will do this by dragging the blocks from the Template Panel into
the diagram sheet.

• Drag the Resistor 1 block into the diagram sheet. To do this, click the block in the Template Panel to
select it, hold down the left mouse button, drag the cursor into the desired position on the diagram sheet
and release the mouse button. Your screen will look like the figure shown next.

• Next, drag the Resistor 2 and Resistor 3 blocks into the diagram sheet.

3.4.5  Arrange and Connect the Blocks
You are now ready to arrange and connect the blocks in the diagram sheet to create a reliability block
diagram (RBD) that will represent the reliability-wise configuration of the system.

• Place the blocks in a horizontal row with Resistor 1 on the left, Resistor 2 in the middle and Resistor 3
on the right. Drag the blocks as before by clicking the block to select it, holding down the left mouse

Notice that a copy of the block is placed in the diagram sheet and the template block
remains in the Template Panel. Template blocks are like re-usable patterns that you can use
to save time and effort. When you drag a template block into a diagram sheet, a separate
(independent) block is created in the diagram sheet that you can modify to meet the needs
of the particular diagram.
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button, moving the cursor into the desired position and releasing the mouse button. Your diagram sheet
will look like the next figure.

• Now you are ready to connect the blocks to represent the relationships between components of the
system. Select the Resistor 1 component by clicking once on the block. When a block is selected, a blue
outline will appear around the block and object handles will appear at each corner and on all four sides
of the block, as shown next.

When you move the cursor over the object handles in the selected block, a circular target symbol
appears at the tip of the arrow. This target symbol is the anchor for the relationship lines you will draw
between blocks. 

• Move the mouse over the object handles on the Resistor 1 block. When a target symbol appears, hold
down the left mouse button and drag a line from the Resistor 1 block to the Resistor 2 block with which
it will be connected. When the target symbol is located above the second object, release the mouse
button. A relationship line will now connect the two blocks.

• You can also use the Join Blocks tool to connect blocks in the diagram sheet. Connect the Resistor 2
block with the Resistor 3 block by selecting Join Blocks from the Diagram menu or by clicking the
Join Blocks icon.

The cursor will change to display a target symbol at the tip of the arrow. Click the source block
(Resistor 2), hold down the left mouse button and drag a line to the destination block (Resistor 3). When
the target symbol is located above the second object, release the mouse button. The blocks will be
connected with a relationship line. Note that when using the Join Blocks tool to create relationship lines,
you must right-click the diagram sheet to stop adding relationships and return to BlockSim's normal
mode.7

7. If you do not right-click the diagram sheet to return the cursor to its normal mode, you will not be able to perform
other activities in BlockSim. If you are experiencing difficulties with the program, make sure that the cursor is in its nor-
mal mode. A dialogue balloon reminder appears in the upper right of the MDI when the Join Blocks tool is activated.
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• Your diagram will now look like the next figure.8 

3.4.6  Analyze the Diagram
Now that you have defined the reliability characteristics of each component block and arranged and
connected the blocks to represent the system, you are ready to analyze the diagram. 

• Select Analyze from the Tools menu or click the Analyze icon.

• ReliaSoft's Results Panel will appear to display the results of the analysis, as shown next.9

• When you analyze a diagram, BlockSim analyzes the relationships of the components in the system and
presents the reliability-wise configuration mathematically in ReliaSoft's Results Panel. Click Close to
close the Result Panel and return to the diagram sheet.10

8. Notice that the connecting line arrows point from the source blocks to the destination blocks to represent the flow of
the system. The specification of source and destination blocks is relevant to BlockSim's analysis of the system configu-
ration.
9. Note that the first time you analyze a diagram in BlockSim, you will be prompted to indicate whether you would like
to display the Results Panel each time a diagram sheet is analyzed. You can reset this preference on the Other page of the
User Setup by clicking Reset Settings.
10.At this time, you may have noticed that the status in the Status Box in the bottom left corner of the diagram sheet has
changed from EDIT to Analyzed to indicate that system relationships have been analyzed.
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3.4.7  Plot System Reliability
• Now you can generate plots based on the reliability characteristics of the entire system. Select Plot from

the Tools menu or click the Plot icon.

• The plot sheet will appear, displaying the Probability of Failure vs. Time plot, as shown next.11

Additional plots are also available in BlockSim's plot sheet, including Reliability vs. Time, pdf, Failure Rate
vs. Time, Static Reliability Importance, Reliability Importance vs. Time and Availability vs. Time. Select a
plot type from the Plot Type drop-down menu, as shown next.

• Now close the plot by clicking the Close button in the top right corner of the plot sheet.

11.If you have previously opened a plot sheet in BlockSim, the plot type of the last plot that was created will appear. If a
plot other than the Probability of Failure vs. Time plot appears, select Probability of Failure vs. Time from the Plot
Type drop-down menu.
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• When you are asked if you want to insert the plot into the project, click Yes. A Plot Name window will
appear, as shown next. Type a plot name and click OK or click OK to accept the default name.

• Click the Project Explorer icon to place the focus on the Project Explorer.

You can see that a plot file has been added to the project in the Plots directory of the Project Explorer.
Now return the focus to the diagram sheet, Diagram 1, by double-clicking its name in the Project
Explorer.

3.4.8  Calculate System Reliability
In addition to generating system reliability plots, BlockSim is also capable of calculating standard system
reliability metrics based on the exact system reliability function.

• To calculate the reliability of the system at a specified time, select Quick Calculation Pad from the
Tools menu or click the QCP icon.

The Quick Calculation Pad (QCP) will appear. Standard reliability calculations can be obtained using
the first page of the QCP, the General page.
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• To determine the reliability of the system at 50 days, select Std. Probability Calculations under
System Calculations. Under Required Input from User, enter a Mission End Time of 50. Finally, click
Calculate and the results of the calculation will appear under Results, as shown next.

• You can see that the reliability of the system at 50 days is 0.7408 or about 74.08%. Click Close to close
the Quick Calculation Pad and return to the diagram sheet.

3.4.9  Save and Close the Project
Now save the project as 1stStep.rsw. To do this, select Save Project from the File menu or click the Save
Project icon.

In the Save Project As window, enter 1stStep as the filename and click Save. If you are working with an
evaluation copy of BlockSim, you will not be able to save the project. In this case, leave the project open and
proceed with the rest of the examples in the training guide. 

After saving the file, close the project by selecting Close Project from the File menu. You will now be
looking at the MDI without any projects open.



4  Step-by-Step Examples

4.1  Detailed Examples

4.1.1  Example 1
A computer consists of two Hard Drives and a Circuit Board. The two Hard Drives operate reliability-
wise in parallel within the system. The reliability and optimization characteristics of each component
are presented in the table shown next.

Do the following:

• Create a reliability block diagram (RBD) of the system.

• Calculate the reliability of the system at 730 days (2 years) of operation.

• Calculate the reliability of the system at 730 days if the Hard Drive 1 component is removed
from the system.

Component Failure 
Distribution Parameters Max Achievable 

Reliability
Feasibility of Increasing 

Reliability

Hard Drive 1 Weibull
Beta = 2.5

Eta = 3000 days
Gamma = 0

.999 Moderate

Hard Drive 2 Exponential Mean Time = 10000
Gamma = 0 .999 Easy

Circuit Board Weibull
Beta = 1.5

Eta = 5000 days
Gamma = 0

.999 Hard
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• Determine the optimum scenario for increasing the reliability of each component in order to achieve a
system reliability of 0.98 (or 98%) at 730 days of operation.

Solution

• Create a new project by selecting New Project from the File menu or by clicking the New Project icon.

Select the Example1.rst template from the Template Preview window and click Select. The selected
template will open in the new project. You will be prompted to enter names for the new diagram sheet.
Accept the default name. The Project Explorer and a blank diagram sheet will appear. Your screen will
look like the picture shown next.

• The diagram sheet is the workspace in which you will create simple or complex diagrams that represent
the reliability characteristics of systems or processes. The Project Explorer appears behind the diagram
sheet. View the Project Explorer by clicking on it behind Diagram 1, by selecting View Project
Explorer from the View menu or by clicking its icon.

• The template, Example1, appears in the Template Panel on the left side of the MDI. You are now ready
to build a simple reliability block diagram (RBD) by dragging blocks from the Example1.rst template
into the diagram sheet.

• Place the focus on Diagram 1 again by double-clicking its name in the Project Explorer or by clicking
the diagram itself located behind the Project Explorer.

• Drag the Starting block into the diagram sheet. To do this, click the block in the Template Panel to select
it, hold down the left mouse button, drag the cursor into the desired position on the diagram sheet and
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release the mouse button. The Starting block will represent the starting point of the computer system in
this example. Your screen will look like the figure shown next.

• Now drag the Hard Drive and Circuit Board blocks from the Template Panel into the diagram sheet.
Drag a second Hard Drive block into the diagram to represent the second Hard Drive component in the
system. The diagram sheet will now contain four blocks and the Example1.rst template will be
unchanged, as shown next.
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• Double-click the Starting block in the diagram sheet to open the Block Properties window, shown next.

In this window, you can define the reliability characteristics of the component. Because this block does
not represent a component of the system with failure characteristics to be taken into account, de-select
the Block Can Fail option to indicate that the component cannot fail. Because the component cannot
fail, the other options on the Failure page are unavailable. Click OK to close the Block Properties
window.

• The Starting block is defined as a block that cannot fail. The system in this example contains only three
components: two Hard Drives and a Circuit Board. The Hard Drives are connected in parallel.
Therefore, the original system would look like the figure shown next.

However, this original system contains two starting points (Hard Drive 1 and Hard Drive 2). A
BlockSim diagram must have exactly one starting point and one ending point. Therefore, a single
starting point (represented by the Starting block) that does not possess failure characteristics was
introduced to close the system without impacting reliability calculations. 

• The Circuit Board block has also already been defined with the failure characteristics of that
component. The failure distribution properties have already been set in the template block. Move the
mouse over each block within the template to view the pop-up tool tip text. The tool tip text displays the
failure distribution properties of the block over which the cursor is positioned. You can change the
properties of the block within the diagram sheet or within the template. If you change the properties of a
block within the template, then each time the block is dragged into the diagram sheet, the block's
properties will reflect the values specified in the template.

Hard Drive 2

Hard Drive 1

Circuit Board
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• Now, double-click the Hard Drive block at the top of the diagram sheet to define the characteristics of
the Hard Drive 1 block. Be sure that the following options and properties have been defined:

•  Block Name: Hard Drive 1

•  Block Can Fail: Selected

•  Failure Distribution: Weibull

•  Beta: 2.5

•  Eta: 3000 days

•  Gamma: 0

•  Static Block: Not Selected

• Click OK to close the Block Properties window.

• Double-click the other Hard Drive block to define the Hard Drive 2 block. Be sure that the following
options and properties have been defined:

•  Block Name: Hard Drive 2

•  Block Can Fail: Selected

•  Failure Distribution: Exponential

•  Mean Time: 10000

•  Gamma: 0

•  Static Block: Not Selected

• Click Graph to update the pdf plot to graphically represent the current failure distribution. The window
will look like the next figure.

• Now you are ready to connect the blocks to represent the relationships between the components of the
system. Use either connection method to connect the Starting Block to the Hard Drive 1 block, the
Starting Block to the Hard Drive 2 block, the Hard Drive 1 block to the Circuit Board block and the
Hard Drive 2 block to the Circuit Board block. If you use the Join Blocks tool to add relationship lines,
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be sure to right-click the diagram once the relationships have been made in order to return to
BlockSim's normal mode. Your screen will look like the next figure.

Notice that the Hard Drive blocks are diagrammed in parallel to show that if one Hard Drive component
fails, the system will continue to operate with the other hard drive component. Now that you have
defined the reliability characteristics of each component block and arranged and connected the blocks to
represent the system, you are ready to analyze the system.

• To analyze the system, select Analyze from the Tools menu or click the Analyze icon.

• ReliaSoft's Results Panel will appear, displaying the results of the analysis, as shown next. Click Close
to close the Result Panel.
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• Now you can generate plots based on the reliability characteristics of the entire system. Select Plot from
the Tools menu or click the Plot icon.

The plot sheet will appear, displaying the Probability of Failure vs. Time plot, as shown next.

• Click the Add Plot to Project icon to add the plot to the project.

The Plot Name window will appear, which allows you to name the plot. Click OK to accept the default
name, Probability of Failure vs. Time (Diagram 1). 

• Now view the Project Explorer by selecting Project Explorer from the View menu or by clicking the
View Project Explorer icon.

You will notice that Probability of Failure vs. Time (Diagram 1) has been added to the project under
Plots in the Project Explorer. Now return the focus to the plot sheet. Close the plot by clicking the Close
(X) button in the top right corner of the plot sheet. You will now be looking at the diagram sheet.

• BlockSim also allows you to obtain standard reliability results based on the exact system reliability
function. To calculate the reliability of the system at 730 days, the Quick Calculation Pad (QCP) will be
used. Select Quick Calculation Pad from the Tools menu or click the QCP icon.
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The QCP will appear, as shown next. 

• The QCP contains two pages, the General page and the Optimization page. On the General page, select
Std. Probability Calculations under System Calculations to determine the reliability of the system.
Under Required Input from User, type a Mission End Time of 730. Finally, click Calculate and the
results of the calculation will appear under Results, as shown next.

You can see that the reliability of the system at 730 days is 0.9438 or 94.38%. Click Close to close the
Quick Calculation Pad and return to the diagram sheet.

• Next, you will determine the reliability of the system if Hard Drive 1 is turned off or absent from the
system. BlockSim allows you to perform “what-if” calculations based on the RBDs you create. You can
toggle the status of individual blocks on or off to indicate whether the component is active or inactive
and then obtain reliability results for the system under those hypothetical conditions. 
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• To toggle the status of Hard Drive 1 to “off,” right-click the block and select Toggle Block On/Off from
the shortcut menu that appears.1 A red X will appear on the block to indicate that the component is
inactive, as shown next.

• Now re-open the QCP. Select the Std. Probability Calculations option and specify 730 as the Mission
End Time. Click Calculate and the results will be displayed under Results. You can see that with Hard
Drive 1 inactive, the reliability of the system at 730 days decreases from 0.9438 (94.38%) to 0.8792
(87.92%). Close the QCP.

• Now toggle the status of the Hard Drive 1 block back to “on” by de-selecting the Toggle Block On/Off
option from the shortcut menu. The red X will disappear, indicating that the component is active.

1. You can also click the block to select it and then select Toggle Block On/Off from the Diagram menu.
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• BlockSim also provides the capability of performing optimization calculations to determine the best
way to achieve a system reliability goal by improving the reliability of individual components. Double-
click the Hard Drive 1 block to open the Block Properties window. Click the Optimization tab to
display the Optimization page. On this page, you can define the optimization characteristics of the
selected component. Enter 0.999 (default) into the Max Achievable Reliability input box to indicate the
highest reliability value that can reasonably be achieved for the component. Drag the marker on the
Feasibility scale to Moderate to indicate that it is moderately difficult (or costly) to increase the
reliability of the component. Click Graph to update the Cost vs. Reliability plot in the graphics screen
to the right. The window will look like the next figure.

• Click OK to return to the diagram sheet. Now, right-click the Hard Drive 1 block and select Toggle
Optimize Status from the Diagram Block shortcut menu.2 A green box will appear at the bottom right
corner of the block, as shown next, to indicate that the reliability of this component is to be considered
in the optimization algorithm.

• Repeat these steps to define the optimization characteristics of the Hard Drive 2 and Circuit Board
blocks. For the Hard Drive 2 block, the Max Achievable Reliability is 0.999 and the Feasibility is Easy.
For the Circuit Board block, the Max Achievable Reliability is 0.999 and the Feasibility is Hard. Be
sure to select the Toggle Optimize Status option for both blocks.

• Re-open the QCP and click the Optimization tab. The Optimization page allows you to set up and
conduct the optimization algorithm for the system. For Mission End Time, type 730; for Reliability

2. You can also select the block and then select Toggle Optimize Status from the Diagram menu.
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Goal, type 0.98; for Iterations, accept the default value of 50.3 Select the Show Results Automatically
option, as shown next.

• Click Calculate to begin the optimization. Because the Show Results Automatically option is
selected, when the optimization calculations are complete, the results will appear in ReliaSoft's Results
Panel, as shown next.4

3. The Iterations input box allows you to enter the maximum number of iterations of the optimization algorithm to be
calculated in order to obtain a solution. As the complexity and number of units in the system increases, a greater number
of iterations may be required.
4. If the Show Results Automatically option is not selected, you can click the Report button to display the results in
ReliaSoft's Results Panel.
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The reliability goals for each optimized component, displayed in the R_goal(730) column, represent the
optimum scenario for increasing component reliability in order to achieve the system reliability goal of
0.98 (or 98%) while minimizing the system cost. The number of equivalent units that would have to be
placed in parallel to achieve this reliability is shown in the N.E.P.U. column, which stands for Number
of Equivalent Parallel Units. Click Close to close the Result Panel and click Close to close the Quick
Calculation Pad.

• At this time, save the project as Example1.rsw. To do this, click the Save Project icon or select Save
Project from the File menu.

• In the Save Project As window, enter Example1 as the filename and click Save. After saving the file,
leave the project open, as it will be used in the next example.

4.1.2   Example 2
The Circuit Board from Example 1 was examined further to determine the major failure modes so that its
reliability could be improved. It was found that most of the failures were due to the failure of the Processor
and the Fan. The properties for the Processor and Fan are shown in the table below.

The Processor and Fan are connected reliability-wise in series. 

Do the following:

• Create an RBD for this subsystem.

• In the previous example, it was found that the reliability of the Circuit Board would be increased from
0.9457 to 0.9806 for the system to reach a reliability goal of 0.98. Find the optimized reliabilities for the
Processor and Fan in order to achieve this goal.

Solution

• First, insert another diagram into the project. To do this, select Add New File from the File menu and
then Add New Diagram or right-click inside the Project Explorer and select Add New File then Add
New Diagram from the shortcut menu. A new, blank diagram sheet will be placed into the project under
Diagrams in the Project Explorer and it will also appear in the MDI. 

• Next, open an existing template called Example2.rst. To do this, select Import File then Template from
the File menu or right-click inside the Project Explorer and select Import File then Template. The

Component Failure 
Distribution Parameters Max Achievable 

Reliability
Feasibility of 

Increasing Reliability

Processor Weibull
Beta = 2.3

Eta = 7655.19 days
Gamma = 0

.999 Moderate

Fan Exponential Mean Time = 14231.83
Gamma = 0 .999 Easy
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Template Preview window will open. Select the Example2.rst file from the list of files (in the
BlockSim\Templates directory) and click Select. Your screen will look like the next figure.

You can now see that two templates are open at the same time. The active template is indicated by a
yellow bar in the Template Panel. You can switch between templates by clicking the bar with the
template's name.

• Double-click the Processor block in the Example2 template to open the Block Properties window. Be
sure that the Block Can Fail option is selected on the Failure page. Next, select Weibull as the failure
distribution and enter the known parameter values (see table on page 32). Click Graph to view the pdf
plot for the current parameter values based on the selected distribution. Your screen will look like the
figure shown next.



Step-by-Step Examples                                                                                                                         BlockSim

34      http://BlockSim.ReliaSoft.com      

• Now click the Optimization tab to display the Optimization page of the Block Properties window. Type
the proper values for the Max Achievable Reliability and select the correct Feasibility option, as shown
next. Be sure to click Graph so that the Cost vs. Reliability plot reflects the current settings.

• Click OK to accept the current block properties and close the window.

• Double-click the Fan block in the template to open the Block Properties window and enter the
appropriate block properties for the Fan using the same process described for the Processor. After you
have entered all of the properties, click OK.

• Now drag one Processor block and one Fan block from the template into Diagram 2 and connect the
blocks by dragging a relationship line from the Processor block to the Fan block. 

• Right-click the Processor block and select Toggle Optimize Status from the shortcut menu. A green
box will appear at the bottom right corner of the block to indicate that the reliability of this component
is to be optimized. Do the same for the Fan block. Your screen will look like the figure shown next.
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• Analyze the system by selecting Analyze from the Tools menu or by clicking the Analyze icon.

• ReliaSoft's Results Panel will appear, displaying the results of the analysis. Click Close to close the
Results Panel.

• Next, optimize the reliabilities of the Processor and Fan so that the system reliability meets the
reliability goal of 0.9806. Open the Quick Calculation Pad (QCP) and click the Optimization tab. Make
sure that 730 is entered for the Mission End Time, the Reliability Goal is set at 0.9806 and the number
of Iterations is 50 (default). In addition, Show Results Automatically will be selected. The QCP will
look like the next figure.
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• Click Calculate to conduct the optimization calculations. The results are shown next.

As the results indicate, to achieve a reliability goal of 0.9806, the reliability of the Processor must be at
least 0.9955 and the reliability of the Fan must be at least 0.985.

• Click Close to close the Results Panel and click Close to close the QCP. Save the project as
Example2.rsw and leave the project open, as it will be used in the next example.
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4.1.3  Example 3
In BlockSim, you have the ability to include subsystems within selected blocks. This allows you to drill
down or view the subsystems within a particular component. This example will demonstrate this aspect of
BlockSim. At this point, you will still be working with the data and diagrams used in Examples 1 and 2.

Do the following:

• Include the Fan and Processor as a subsystem within the Circuit Board block.

• Calculate the reliability of the system at 730 days.

Solution

• To begin, return the focus to Diagram 1. This is the diagram with two Hard Drives and a Circuit Board.
Double-click the Circuit Board block to open the Block Properties window.

• In the Block Properties window, click the Other tab. On the Other page, select the Block As Diagram
option. Below the Block As Diagram option, a drop-down menu will appear. This menu contains a list
of all available diagrams in the current project. Select Diagram2 from this list. This is the file with the
Processor and the Fan that you were working with in Example 2. The selected diagram will be displayed
in the graphics screen on the right side of the Block Properties window. Your screen will look like the
figure shown next.

You can zoom in on the diagram displayed in the graphics screen by left-clicking the screen and you can
zoom out by right-clicking the screen. Click OK to apply the current settings to the Circuit Board block
and close the Block Properties window.
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• The Circuit Board block has now been modified. It still contains the original picture, but it is now in the
shape of a folder. Subdiagram blocks (blocks that contain subsystems or diagrams) are identified in
BlockSim in this way.

The Circuit Board is now defined by the subsystem containing the Fan and Processor. In other words,
the block definition indicates that the Circuit Board is composed of one Fan and one Processor. In
reality, this is obviously not the case. However, this example simply shows you how one block can
represent another diagram in BlockSim.

• To calculate the reliability of the system at 730 days, the QCP will be used. Select Quick Calculation
Pad from the Tools menu or click the QCP icon.
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• Select Std. Probability Calculations under System Calculations. Type 730 for the Mission End Time
and click Calculate. The results are shown next.

The reliability of the system at 730 days is 0.9438 (94.38%), which is the same as the result returned in
Example 1.

• Save and close the project. You can close the project by selecting Close Project from the File menu or
by right-clicking in the Project Explorer and selecting Close Project from the shortcut menu that
appears.
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4.1.4  Example 4
ACME Company manufactures subsystems for oil refinery plants. One of the subsystems that ACME
manufactures consists of two Power Generators, three Pumps and one Valve. The two Generators are
identical to each other, as are the Pumps. The Pumps are in a 2-out-of-3 configuration. The system
configuration is shown next.

The following table presents the failure data for the Generators.

The table shown next presents the failure distribution data and parameter values for the Pumps and the
Valve.

Number in Group State Time-to-failure, hr
1 F 1150
1 F 1660
1 S 1660
5 S 1850
2 F 3000
4 S 3000
1 S 3200
4 S 4150
1 F 4330
1 F 4800
4 S 4850
1 F 5600
1 F 6100
1 F 7800
3 S 8500
1 F 8750
2 S 8750
3 S 10100
1 S 11500
3 S 12000

Component Failure Distribution Parameter Values

Pumps Mixed Weibull
(2 subpopulations)

1 = 0.589,  = 6343.390 hrs, Portion[1] = 0.2695

2 = 2.394,  = 20301.856 hrs, Portion[2] = 0.7305

Valve Exponential Mean Time = 830288.94

Generator

Generator

Pump

ValvePump

Pump

β η1

β η1
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Do the following:

• Using the Weibull++ software, determine an appropriate failure distribution for the Generators based on
the given data.

• Estimate the parameters of the selected distribution using maximum likelihood estimation (MLE).

• Generate a table of system reliabilities given a start time of 1000 hours and an end time of 5000 hours
with a time increment of 1000 hours.

Solution

• Create a new project and select the Example4.rst template from the Template Preview window (in the
BlockSim\Template directory) and click Select. The selected template will open in the new project. 

• You will be prompted to enter a name for the new diagram sheet. Accept the default name. The Project
Explorer and a blank diagram sheet will appear. Your screen will look like the picture shown next.

• Double-click the Generator block inside the Template Panel. The Block Properties window will appear.
The properties for the Generator block have not been set. Although the parameter values are currently
unknown, life data has been obtained based on life tests conducted on the Generator. This data, given in
the table on page 40, can be used to calculate the parameters of the failure distribution for the Generator
block.

• Be sure that you are on the Failure page of the Block Properties window. Click the Compute
Distribution button in the bottom left corner. This will launch ReliaSoft's life data analysis software,
Weibull++.5 The version of Weibull++ that will appear (Weibull++ 5.0 or Weibull++ 6) will depend on
which version was selected upon installation of the BlockSim software. The process for both versions is
similar and this example uses Weibull++ 6. 

5. Weibull++ must be installed on your computer in order for you to utilize the Compute Distribution option.
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• Once Weibull++ has been activated, the Weibull++ Data Type Expert will appear.6 You will use the
Data Type Expert to create the appropriate Data Entry Spreadsheet for the Generator component's life
data. In the Data Type Expert, click the Times to Failure button, the with Right Censored Data
(Suspensions) button and the with Grouped Observations button. Click OK. A Data Entry
Spreadsheet will be created for you based on your selections. 

• Enter the data given for the Generator into the Data Entry Spreadsheet, as shown next.

• Maximum likelihood estimation (MLE) will be used for the parameter estimation. You can specify this
by clicking the Set Analysis tab on the Data Folio Control Panel. Select the Maximum Likelihood
(MLE) option from the Analysis Method area. Return to the Main page of the Control Panel by clicking
the Main tab.

• The Distribution Wizard utility in Weibull++ conducts a variety of goodness-of-fit tests designed to
suggest the best distribution for your data. Select Distribution Wizard from the Data menu or click the
Distribution Wizard icon.

• The Distribution Wizard will appear. Click Begin Auto Run so that the Distribution Wizard can go
through the process of suggesting a distribution. After the Distribution Wizard has finished conducting

6. If the Data Type Wizard appears instead, click the Data Type Expert button to display the Data Type Expert.
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the tests, the 2-parameter Exponential distribution will be suggested (indicated by the 1 in the Ranking
column next to Exponential 2), as shown next.

• Click Implement Suggestion to indicate that you would like to calculate the parameters using the 2-
parameter Exponential distribution. The Distribution Wizard will close and you will now be viewing the
Data Entry Spreadsheet with the entered data and the parameters calculated, as shown next.

• Close Weibull++ by selecting Close from the File menu. A message box will appear to ask if you would
like to save the changes made to the Data Folio. Click Yes and save the Data Folio as Example4.rw6.
The next message box asks if you would like to update the block's distribution information. Click Yes.7

7. In Weibull++ 5, a third message box may appear to inform you that the failure distribution pdf plot cannot be dis-
played in the graphics screen on the right side of the Block Properties window because of insufficient resolution in the Y
direction. Click OK.
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• Notice that the parameter values that were calculated using Weibull++ have been inserted as the
parameter values of the failure distribution of the Generator block, as shown next. Click OK to accept
the current block properties.8 

• Now you will arrange the blocks in the diagram. Because BlockSim's diagrams must have only one
starting point, you will use the Starting block as the starting point of the diagram. Place the Starting
block on the left side of the diagram. Drag one Generator block into the diagram and place it above and
to the right of the Starting block. Drag another Generator block into the diagram and place it below and
to the right of the Starting block. Drag the Pump block into the diagram three times, placing them in a
vertical line to the right of the Generator blocks. Drag the Valve block into the diagram and place it on
the far right side. Your diagram will look like the figure shown next.

8. Note that because the Exponential parameter in BlockSim is defined by default as “Mean Time,” the “Lambda”
parameter calculated in Weibull++ was converted to “Mean Time” when you updated the block's distribution informa-
tion. If “Lambda” had been defined as the Exponential parameter, the block properties would have been updated with the
calculated Lambda value. You can change the Exponential parameter definition from the Calculations page of Block-
Sim's User Setup.
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• Now you will connect the blocks by dragging relationship lines between them. Connect the starting
block to each of the Generator blocks. The Generator blocks will be connected to each of the Pump
blocks through a Node. A Node is a different type of block that can be defined to indicate the number of
paths that must successfully pass through the block in order for the system to succeed (k-out-of-n). To
place a node into the diagram, select Add Node from the Diagram menu or click the Add Node icon.

The cursor will turn into a pointing hand holding a circle.

• Place the cursor in the diagram between the Generator blocks and the Pump blocks and click to place
the Node. Your screen will look like the figure shown next. 

• Connect each Generator block to the Node. Connect the Node to each Pump block. Then double-click
the Node to open the Node Properties window, shown next.

• In the Node Name input box, type Node 1. In the Number of Paths Required input box, type 1, to
indicate that one working Generator is required in order for the system to succeed. Make sure the Node
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Can Fail option is not selected.9 Click OK to close the Node Properties window. Your screen will look
like the figure shown next.

• You will also use a Node to represent the k-out-of-n configuration of the Pump blocks in relation to the
Valve block. Place a Node between the Pump blocks and the Valve block. Double-click the Node to
open the Node Properties window. In the Node Name box, type Node 2. In the Number of Paths
Required box, type 2 to indicate that two working pumps are required in order for the system to operate.
Make sure the Node Can Fail box is not selected. Click OK to close the Node Properties window. 

• Now connect each Pump block to the Node 2 block and connect the Node 2 block to the Valve block.
Your diagram will look like the figure shown next.

• Analyze the system by selecting Analyze from the Tools menu or by clicking the Analyze icon.

9. If the Node Can Fail box is selected, a Define Distribution button becomes available in the Node Properties window.
Clicking the Define Distribution button opens a Block Properties window for the Node, where the failure and repair
properties can be set for the Node.
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• ReliaSoft's Results Panel will appear to display the results of the analysis, as shown next. Close the
Results Panel by clicking Close.

• Insert a spreadsheet into the project by selecting Add New File from the File menu and then selecting
Add New Spreadsheet. A spreadsheet will open in the MDI. You can also see that the spreadsheet has
been added to the project in the Project Explorer. 

• Return the focus to Spreadsheet 1. The Function Wizard will be used to generate a table of system
reliabilities. Open the Function Wizard by selecting Function Wizard from the Tools menu or by
clicking the Function Wizard icon.

The diagram sheet to which the Function Wizard is linked (in this case, Diagram 1) is displayed in the
drop-down menu in the bottom left corner. The Function Wizard is linked to the diagram sheet that is
active when the Function Wizard is activated. 
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• Scroll through the list of available functions and select Table of Reliabilities given a time range. Type
1000 for the Iter. Start Time, 5000 for the Iter. End Time and 1000 for the Iteration Incr. in the input
boxes, as shown next.

• Click OK to generate the table in the spreadsheet. The generated table is shown in the next figure.

• Save the project as Example4.rsw and close the project.
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4.1.5  Example 5
Consider the following telecommunications network:

The letters A-E represent the communication centers, where A is the main center. F is a city to which service
is being supplied. The numbers 1-8 represent the communication lines. Communication lines 3 and 6 can
operate in two directions, e.g. from B to D and from D to B. The communication centers cannot fail, while
the failure rate ( ) for the communication lines is 1.3E-6 failures/hour. The repair distribution for the
communication lines is normal with a mean time of 101.35 hours and a standard deviation of 62.1 hours.

Do the following:

• Find the reliability of the system at 17,520 hours.

• Find the estimated time at which 25% of the communication systems that are in operation will have
failed.

• Using the Reliability/Maintainability Simulation window, estimate the total downtime for the system
for one year (8,766 hours).

• Add this system to a template so that the entire system can be added to a national communications
system.

Solution

• Create a new project by selecting New Project from the File menu or by clicking the New Project icon.

• Select the Example5.rst template from the Template Preview window and click Select. The selected
template will open in the new project. When you are prompted to enter a name for the new diagram

λ
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sheet, accept the default name. The Project Explorer and a blank diagram sheet will also appear. Your
screen will look like the picture shown next.

• For this example, the Exponential parameter will be defined as “Lambda” instead of “Mean Time.” To
define the Exponential parameter as Lambda, select User Setup from the File menu to open the User
Setup window. Click the Calculations tab to display the Calculations page of the User Setup and de-
select the Use Mean Time for the Exponential distribution option at the bottom of the window, as
shown next.

When the Use Mean Time for the Exponential distribution option is not selected, you will be
prompted to enter a value for lambda each time you define a block with the exponential distribution.

• Click OK to close the User Setup window.

• Double-click the Com Center block in the template to open the Block Properties window. The Com
Centers designated by the letters A-E cannot fail. Therefore, make sure the Block Can Fail option is not
selected and click OK. 
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• Now double-click the Com Line block. The failure distribution associated with each Communication
Line is the Exponential distribution. Select Exponential under Failure Distribution. Enter 1.3E-6 for
the value of Lambda and 0 for the value of Gamma. 

• Click the Repair tab to open the Repair page of the Block Properties window. Click to select the Block
Can Be Repaired option. The Repair Distribution options will become available. Select Normal as the
repair distribution and enter 101.35 for the Mean value and 62.1 for the Std value, as shown next.

• Click OK to accept the block properties and close the window. Finally, double-click the City block. As
is the case for the Com Centers, the City cannot fail. Click to de-select the Block Can Fail option and
click OK.

• The Communication Lines are the most important blocks in this example. The Communication Centers
cannot fail and will be used as Nodes within the RBD. They will be used to direct the Communication
Lines. In addition, because Lines 3 and 6 flow in two directions, multiple representations of Lines 3 and
6 and Communication Centers B-E must be included. A relationship line within BlockSim cannot flow
in two directions at the same time. In other words, there can be no circular paths. When constructing the
RBD, be sure to change the name of each Com Line and Com Center block within the diagram to
represent the proper Communication Line. You can change the name of the block by double-clicking it
to open the Block Properties window. The Block Name input box is in the upper right corner. Designate
each Communication Line as Com 1, Com 2, etc. Designate each Communication Center as Com A,
Com B, etc. A representation of the RBD to be constructed is shown next.
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• The RBD constructed using BlockSim is shown next.

• Analyze the system by selecting Analyze from the Tools menu or by clicking the Analyze icon.

• ReliaSoft's Results Panel will appear, displaying the results of the analysis. Click Close to close the
window.

• The Quick Calculation Pad (QCP) will be used to calculate the reliability of the system. To access the
QCP, select Quick Calculation Pad from the Tools menu or click the QCP icon.

• Select Std. Probability Calculations under System Calculations. Type 17520 for the Mission End
Time and click Calculate to return the system reliability, as shown next.

The reliability of the system at 17,520 hours is 0.9984 (99.84%).
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• The second question requires the time at which 25% of the communication systems in operation will
have failed. Select BX Information under System Calculations. Type 25 in the BX% Information At
input box and click Calculate to return the result, as shown next.

The time at which 25% of the communication systems will fail is approximately 24.5817E+4 hours. 

• Close the QCP by clicking Close.
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• You will now use BlockSim's Reliability/Maintainability Simulation utility to analyze the system for
one year of operation.10 Select Simulate from the Tools menu or click the Simulate icon.

• The Reliability/Maintainability Simulation window will open. Click the Maintainability tab to open
the Maintainability page.

• On the Maintainability page, type 8766 in the End Time field. Type 10 in the Increments field, which
allows you to specify the maximum number of iterations of the optimization algorithm to be conducted
in order to obtain a solution. Select the Use Seed option and input a Seed Value of 1. Using a seed for
the simulation allows you to replicate these results. The window will look like the figure shown next.

• Click the Setup tab to access the Setup page. Type 10000 in the Number of Simulations input box,
which allows you to specify the number of simulations to be performed to obtain a solution. Return to
the Maintainability page of the window and click Simulate to begin the simulation. 

10.The calculations performed in the QCP are based only on the failure information of the components. The Reliability/
Maintainability Simulation utility uses the repair information of the components in order to obtain such results as point
availability, mean availability, etc.
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• The results will be displayed in ReliaSoft's Results Panel, as shown next.

As you can see, the down time for the system is 0 hours of the 8766 total hours. 

• These results can be sent to a spreadsheet by clicking the Transfer to Spreadsheet icon.

• When you are prompted to enter a name for the new spreadsheet, accept the default name.

• Close the Result Panel and the Reliability/Maintainability Simulation window. You can see that the
spreadsheet has been added to the project in the Project Explorer. 

• BlockSim also allows you to add entire diagrams to templates. This makes it possible to represent an
entire system with one block and to re-use that block in multiple diagrams and/or projects. To add the
current system to the Example5 template, first save the project as Example5.rsw. Then right-click the
diagram sheet and select Add Diagram to Template from the shortcut menu that appears. BlockSim
will automatically save the diagram and a subdiagram block will appear within the Example5 Template
Panel just below the other blocks, identified by the folder graphic, as shown next.
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• Double-click the newly created subdiagram block to open the Block Properties window. On the Other
page, select Block As Diagram. The system will be displayed in the graphics screen on the right. Type
TeleComm in the Block Name input box, as shown next.

• Click OK to close the Block Properties window. As you can see, the block name Diagram1 has been
renamed to TeleComm, as shown next.

• Finally, the block can be represented with a picture, if desired. Select the Telecomm block and click the
Block Graphic icon.
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• The Graph File Manager will open to allow you to select a bitmap graphic (*.bmp) for display on the
block, as shown next. (Please note that the appearance of the Graph File Manager will depend on the
directory that is opened in the Graph File Manager.)

• Select a picture from the list and select Select Graphic from the File menu to represent the system
within the block.

• You can now close the project. The Save Changes window will appear, prompting you to save the files
to which you have made changes. Make sure that all files in the Save Changes window are selected and
click Yes. The Telecomm block can now be inserted into another completely separate diagram if
necessary. The subdiagram block now represents the entire system that was created during this example.

The Graph File Manager allows you to preview previously saved bitmap (*.bmp) graphics that can
be used to display on BlockSim blocks. To use the Graph File Manager, use the Browse button and/
or drop-down menu at the top of the window to select a directory that contains (*.bmp) files. A
preview of each graphic in the directory will appear in the preview area. The filename for each
(*.bmp) file in the selected directory is displayed in the filename box on the left side of the window.
You can select a filename or preview image and then select Select Graphic from the File menu to
display a graphic on the current block. You can also double-click a file name or preview image to
display it on the current BlockSim block.





5  Practice Questions

The following practice questions can be performed using BlockSim. The answers to these practice
questions can be found in Chapter 6.

5.1  Practice Question 1
Consider the following circuit bridge system:

All components are identical, following an exponential life distribution with  = 8.126E-4 failures/
day.

1. Create a template to create the RBD and customize the template to your liking.
2. Create the reliability block diagram for this system.
3. Estimate the reliability at 200 days using the QCP. 
4. Create the Reliability vs. Time plot.
5. Insert the Reliability vs. Time plot into the project.
6. Rename the diagram as “Bridge System.”
7. Export the diagram as “Bridge System.rsb.”
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8. Save your project as “QUEST1.RSW” and leave it open.

5.2  Practice Question 2
The reliability predictions of Practice Question 1 can also be performed using simulation. However, the
results are dependent on the number of simulations. This example will take you through such a scenario. 

1. QUEST1.RSW will already be open.
2. Open the Reliability/Maintainability Simulation window by clicking its icon.

3. On the Reliability page, enter an End Time of 200 and an Increments value of 100. 
4. On the Setup page, type 100 for the Number of Simulations. Return to the Reliability page and click

Simulate to perform the simulation. What is the reliability of the system at 200 days? How does this
value compare with the reliability obtained in Practice Question 1?

5. Repeat step 4 with 1000, 5000 and 10000 simulations. When is the reliability estimate closer to the ana-
lytical value obtained in Practice Question 1?

6. Save and close the project.

5.3  Practice Question 3
Consider the following disk array subsystem:

The failure distributions and parameters for each component are:

The Power Supply subsystem is in a 2-out-of-4 configuration. The Fans are in a 2-out-of-3 configuration.
The Hard Drives are also in a 2-out-of-3 configuration.

Component Distribution Parameters

Array Controllers Weibull
 = 1.2,

 = 1953 days.

Power Supply Lognormal
 = 7.0102 (log-mean),

 = 1.2124 (log-std).
Fan Exponential  = 0.000070265 failures/day.

Hard Drive Weibull
 = 2.5,

 = 3000 days.
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Do the following:

1. Create a block for each type of component within a template and customize the template to your liking.
2. Create the RBD and rename the diagram to “Disk Array.” 
3. Obtain the Reliability vs. Time plot. 
4. From the plot, determine:

i. The reliability of these units for a mission of 182 days, R(182days).
ii. The mission duration for the system if a 90% reliability is required.

5. Add the plot to the project.
6. Using the Quick Calculation Pad, determine:

i. The reliability of the system for a mission of 182 days, R(182days).
ii. The reliability for each subsystem/component.
iii. The mission duration for the system if a 90% reliability is required.
iv. Knowing that the system has successfully operated for 182 days, what is the probability that it will

operate successfully for another 182 days?
v. What is the MTTF for the system?

7. Obtain the pdf plot for the system.
8. Obtain the Failure Rate vs. Time plot for these units. From the plot, what is the failure rate of the system

at 182 days?
9. Add a spreadsheet into the project. Using the Function Wizard, obtain:

i. The failure rate at 182 days. 
ii. A table of times given reliability, starting from 0.9 to 0.99 with a 0.01 increment.

10. Export the diagram as “Disk Array.rsb.”
11. Break the system into 4 subsystems by creating 4 new diagrams: an Array Controllers diagram, a Power

Supplies diagram, a Fans diagram and a Hard Drives diagram.
i. Add a new template to the project. 
ii. Add each of the 4 new subdiagrams to the new template.
iii. Create the RBD for the system using the subdiagrams.
iv. Using the QCP, obtain the reliability of this system for a mission of 730 days, R(730days).
v. A reliability goal of 85% is required at 730 days (2 years). Is the reliability goal met? If not, opti-

mize the system if it is known that there is only room for improvement for the two Array Control-
lers and the Power Supplies. In addition, it is known that it is hard to improve the Array Controllers
and much easier to improve the Power Supplies. The maximum achievable reliability is 0.999 for
both subsystems. 

vi. Using the optimum reliability values obtained for the Array Controllers subsystem and for the
Power Supplies subsystem, determine the optimum reliability values at the component level for
these two subsystems. (Hint: Use the subdiagrams.)

12. Save your file as “QUEST3.RSW.”
13. Close the project.
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5.4  Practice Question 4
This example shows how you can import previously created diagrams and use them as components in a new
diagram. Consider the following system in which the Disk Array of Practice Question 3 is connected with
the Bridge System of Practice Question 1, as shown next:

1. Create a new project.
2. Import the previously saved diagrams: Bridge System.rsb and Disk Array.rsb.
3. Create the RBD for the system shown above where the blocks represent the corresponding Disk Array

and Bridge System diagrams that were imported.
4. Estimate the reliability of the system at 200 days.
5. Save the project as “QUEST4.RSW” and close it.

5.5  Practice Question 5
A four-engine airplane has two engines on each wing. It requires at least one engine to be operating on each
wing for a successful mission. Assume that the reliability of each engine is 90% for a specified mission
duration.

1. Create the RBD.
2. Obtain the reliability of the system.
3. Add a new diagram and repeat the example, but this time consider a 2-out-of-4 engine configuration. 
4. When is the reliability of the system higher? Why?
5. What would the reliability of each engine be in the first design in order to achieve the system reliability

of the second design? Since the units are identical, you can assume the same feasibility of increasing the
reliability and maximum achievable reliability for each engine.

6. Save the project as “QUEST5.RSW” and close it.
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5.6  Practice Question 6
A subsystem of a machine is composed of a Ball-Bearing subsystem and a Shaft, as shown below:

The inspection times (in hours) for the Ball-Bearing subsystem are given in the table below.

The life data set for the Shaft is given in the table below.

1. Using the 2-parameter Weibull distribution for the Ball-Bearing data and the Lognormal distribution for 
the Shaft data, estimate the reliability of the system at 1,000 hrs.

2. What is the reliability of each component at 1,000 hrs?

Number in State Last Inspected State State End Time
5 0 F 600
16 600 F 1900
12 1900 F 2900
18 2900 F 3500
18 3500 F 3900
2 3900 F 4500
6 4500 F 5200
17 5200 F 6300
73 6300 S 6300

Number in State State State End Time
1 F 1226
1 F 1943
1 F 2362
1 F 2518
1 F 5462
1 F 6404
1 F 10388
5 S 11772





6  Answers to Practice Questions

The purpose of this section is to provide answers to the Practice Questions in Chapter 5.

6.1  Practice Question 1
2. 

3. R(200days) = 0.9506

6.2  Practice Question 2
4. R(200days) = 0.9400. Not very accurate.
5. The reliability estimated using 100,000 simulations is closer to the analytical value.
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6.3  Practice Question 3
2. 

4. From the Reliability vs. Time plot:

i. R(182days)  0.99

ii. T  530 days

6. Using the QCP:
i. R(182days) = 0.9951
ii. Array Controller: 0.9437

Power Supply: 0.9319
Fan: 0.9873
Hard Drive: 0.9991

iii. T = 527.6891
iv. R(182,182) = 0.9676
v. MTTF = 1316.1014 days

8.  failures/day

9. Using the Function Wizard:

i.  = 7.70425E-005 failures/day 

ii. 
Reliability Time

0.9 527.6891
0.91 505.9283
0.92 483.1063
0.93 458.9627
0.94 433.1295
0.95 405.0584
0.96 373.8714
0.97 338.0091
0.98 294.1975
0.99 232.9436
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11. 
iii. 

iv. R(730days) = 0.7906
v. Array Controller: 0.9301 (no change)

Power Supplies: 0.9228
vi. Array Controller: No change

Power Supplies: 0.7088

6.4  Practice Question 4
4. R(200days) = 0.9423
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6.5  Practice Question 5
1.

Or

2. R = 0.9801
3. For the 2-out-of-4 engine configuration: R = 0.9963
4. The second design, because there is more redundancy in the 2-out-of-4 configuration.
5. The reliability for each engine is: R = 0.957

6.6  Practice Question 6
1. R(1000hrs) = 0.8999
2. Bearings: 0.944841

Shaft: 0.952387


